This project is read-only.

Patchs??

Jan 21, 2008 at 5:08 AM
Patchs??? How does this work? I am trying to apply the last physics patch, but it keeps giving me this error message:


Unhandle exception:
System.NullReferenceExc... : Object reference not set to an instance of an object.
Jan 21, 2008 at 5:29 AM
I just dl the latest build and the latest physics patch and had no problem applying it. Are you using the standard cpc or the custom build and are you running from a standard command prompt or the BE?
Jan 21, 2008 at 5:39 AM
I just tried to run the latest source with the patch and that's not possible. You need the 8993 changeset.
Jan 21, 2008 at 5:40 AM
Edited Jan 21, 2008 at 5:42 AM
I am using the one locate at "tools\extern\cpc". And I tried with both standard command prompt and the BE one. And I was trying with the 8993 changeset.
Jan 21, 2008 at 6:21 AM
Ok, strange.

Ok lets try to rule out some issues:
  • Do your path contain spaces
  • Does the source you try to apply the patch to contain any changes (i.e. did you do any changes to the code)
  • The size of the patch should be 719444 bytes real size (disk size is 720896 bytes)
Jan 21, 2008 at 2:10 PM
Is that error generated by cpc or the game?
Jan 21, 2008 at 2:53 PM
By the cpc.

It had spaces, so a moved it the C: root. But still gives that same error.
No, no changes.
Yes, the size is correct.

Perhpas I could be doing something wrong. The steps are:
Open a command prompty at "tools\extern\cpc". Than I type: cpc applypatch "C:\QuickStartEngine-8993\physics.patch" and press Enter.
Am I doing something wrong? This is the first time that I try to use a patch.
Jan 21, 2008 at 3:03 PM
It could be because you're trying to apply the patch at tools/extern/cpc. cpc has never struck me as an intelligent tool. Try doing this when your working directory is just c:\QuickStartEngine-8993.

It would be something like:

cd c:\QuickStartEngine-8993
tools\extern\cpc\cpc.exe applypatch physics.patch

That should force the proper working directory, if the Windows shell isn't completely lame.
Jan 21, 2008 at 3:08 PM
Nope, It doesn't work either. :(
Jan 21, 2008 at 3:32 PM
What happens if you use the default version of cpc, not the one in the build environment?
Jan 21, 2008 at 5:16 PM
Try

1.) Make a new directory
2.) Within that directory, at the cmd prompt, type: cpc checkout quickstartengine
3.) Download the patch into the root of that directory
4.) From the same place in the cmd prompt, type: cpc applypatch patchnamehere.patch

Now you should be able to run. This is what I usually do, but I haven't tested this one specifically. Is it possible the patch is outdated because of a recent commit?
Jan 21, 2008 at 5:38 PM
The patch is outdated, but he was applying it to the correct (previous) change set.

FYI: There is a new physics patch out now that works with the latest change set. It's the final patch. If I don't hear from Sturm in the next few hours, I'm just going to commit it.
Jan 21, 2008 at 6:07 PM
LordIkon, it worked! Thanks! But I don't understand. I don't anything different of what I was doing.
Jan 21, 2008 at 6:12 PM
Shaw, is the physics for the changeset 9188 than?
Jan 21, 2008 at 6:15 PM
The new physics patch is, yes. The old patch that you would have been using before this morning was for 8993 (I think).

At this point, I could just download the new patch and apply it to 9188.
Jan 21, 2008 at 6:15 PM
And don't forget you need to go download the PhysX System Software.
Jan 21, 2008 at 6:24 PM
Thanks shaw. I already have the PhysX installed.

But now I am having another problem. I deleted the quickstartengine folder, made a new one on another disk partition and when I try to repeat those same steps, it shows me this message:
I type:
cpc checkout quickstartengine.

The message is:
"d:\QuickStartEngine is already under source control"

What does that means?
Jan 21, 2008 at 6:30 PM
d:\QuickStartEngine is a new folder? If you just deleted the internal folders, you might have a few stray _tfs folders lying around. By default, the _tfs folders are hidden and Windows Explorer will not display them unless you configure it to display hidden and system files/folders. Make sure you delete d:\QuickStartEngine completely (not just everything in it), then recreate it.

If that doesn't solve the problem, then I think you have an excessively bugged version of cpc.
Jan 21, 2008 at 6:36 PM


shawmishrak wrote:
If that doesn't solve the problem, then I think you have an excessively bugged version of cpc.


Thanks. It was the hidden folder. ;)
It is not an excessively bugged version of cpc. I just don't know how to use it yet. :)
Thanks. It is all working now.
Jan 21, 2008 at 6:45 PM
I'm working on updating the BE so it will warn you if you do not have PhysX installed (similar to NUnit and VS)